Advice and answers from the ActionSprout Team

It’s not unusual to post a social action link, profile campaign link or article link and see the wrong image and message. Sometimes you won’t see any image or message at all but a blank default form! You know you saved your changes, you double check your content and link, and yet the problem persists.

This problem is due to Facebook caching. Facebook is known to cache, or “remember”, the wrong data for a link. This could result in default content or outdated content being shared.

The good news is there is a way to update this data with Facebook.

To get started, open the Facebook Debugger tool. 

(This is something you’ll want to bookmark)

Next grab the direct link to your content and paste it into that provided field:

Please note: this is the direct link to the piece of content, NOT the link to the Facebook post. 

Then click Fetch new scrape information:

The following page will supply a ton of information. All you need to look at right now is the preview at the very bottom of this page: 

If this preview displays the content you wish to be displayed you’re done! Take that link and post it on Facebook for a final test.

If the preview does not display the desired content, or the link is still appearing wrong on Facebook, scroll to the top of the page and click the Fetch new scrape information button again:

You’ll want to repeat this process until the preview at the bottom of the page, and your post on Facebook, display the correct content.

It’s normal for this process to require a few tries until the correct data comes through. Just keep clicking the Fetch new scrape information button until the preview is correct 😊 

Did this answer your question?