It's frustrating when you've taken the time and effort to craft the perfect post, and for some reason, it's not working the way you wanted it to. You know you saved your changes, you double check your content and link, and yet the problem persists. Sometimes you won’t see even any image or message except a blank default form! 

Take a breath. Don't panic. It’s not unusual to post a social action link, profile campaign link, or article link and see the wrong image and message. 

This problem is due to Facebook caching. Facebook is known to cache (or “remember”) the wrong data for a link. This could result in default content or outdated content showing up instead of what you wanted to post.

The good news is there's a way to update this data with Facebook.

To get started, open the Facebook Debugger tool. 

(As a matter of fact, why don't you go ahead and bookmark it. You'll thank me later.)

Next, grab the direct link to your content and paste it into the provided field:

Please note: You want to paste in the direct link to the piece of content and NOT the link to the Facebook post. 

Then click Fetch new scrape information.

The following page will supply a ton of information. All you need to look, for the moment, is the preview at the very bottom of the page.

If this preview does display the content you were hoping it would, then you’re done! Just take that link and post it on Facebook for a final test.

If the preview does not display the desired content or the link is still appearing wrong on Facebook, scroll to the top of the page and click the Fetch new scrape information button again.

You’ll want to repeat this process until the preview at the bottom of the page (and of course your post on Facebook) display the correct content.

It’s normal for this process to require a few tries until the correct data comes through. Just keep clicking the Fetch new scrape information button until the preview is correct.

Did this answer your question?